Home  >  Support  >  Support Forum  >  Digi printing issues on Solaris 10 (Sparc)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Digi printing issues on Solaris 10 (Sparc)

0 votes
We’re having issues with printing via Digi Etherlite 2 and Etherlite 160 devices from Solaris 10 P11. We have various Digiboxes defined on our other 2 Solaris servers which run Solaris 9 and Solaris 10 P4 (all our Sun servers are Sparc and we don’t use zones) and we can print to these with no issues (this configuration has been in place for a number of years and has been 100% reliable). We have a mix of different line printers. We are using the latest Digi package on all servers (40001174_T.bin). The package is installed fine on our Solaris 10 P11 server. When we try to print to a Digibox from this new server we’re getting mixed results – occasionally it prints fine, but most of the time we’re getting an ‘awaiting retry’ message. When we get this message we are then unable to print to that Digibox port from our Solaris 9/10 P4 servers until we reset the Digibox.

Any help in getting this resolved would be much appreciated!

Thanks

Si
asked Jul 22 in Realport by Mawdsleys New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Could there be a buffer overflow causing this or lack of DCD?

Make sure the "s" device is being used (non-blocking).

I recommend looking over the following knowledge base articles which might prove helpful:

Applying port settings (i.e. flow control):

http://www.digi.com/support/kbase/kbaseresultdetl?id=250

Create a file called "/etc/rc2.d/S99digi" and add the ditty command(s) in it.

Printer Configuration in Solaris:

http://www.digi.com/support/kbase/kbaseresultdetl?id=694

Applying carrier:

http://www.digi.com/support/kbase/kbaseresultdetl?id=899

If these do not work, you might want to test the printer on a built in serial port. If the same behavior is seen there, you will want to contact your Solaris support resource to determine why the spooler is throwing that error.
answered Jul 24 by userid0 Veteran of the Digi Community (993 points)
Contact a Digi expert and get started today! CONTACT US
...