Home  >  Support  >  Support Forum  >  sending TCP/IP data to a remote device attached to Connect ME
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

sending TCP/IP data to a remote device attached to Connect ME

0 votes
Hello:

I have an embedded board with Ethernet connection that has to communicate with a remote RS232 device attached to a Connect ME device. That is, the serial data must be encapsulated in a TCP/IP frame by the CPU, sent by Ethernet cable, received by a Connect ME, converted to RS232, passed to the serial device, and its answer way back to my CPU in reverse order. I am receiving "Access to unopened port" in every frame. I think I should remotely configure the Digi device, but I don't know where to locate such information. Analyzing the communications, I see some prefixes to the information that goes and comes, but I need to know what does those prefixes mean just to build and interpret them.
asked Jul 16 in Plug N' Play by Marti New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
you need to configure the ME into a 'tcp sockets' mode. open it's webUI. go to:
homepage -> configuration -> serial port -> port 1 -> change port profile. select 'tcp sockets', click apply and reboot. you can then connect to the ME on TCP port 2101 and run your test.
answered Oct 28 by kjensen8 Veteran of the Digi Community (569 points)
thank you very much. Since then I used the TCP sockets, but now when my remote serial device answers a packed of around 60 bytes long -30 bytes packets go and come well- the DIGI generates a "data abort" exception. I have posted another forum question concerning that (data abort using tcp sockets).
Contact a Digi expert and get started today! CONTACT US
...