Home  >  Support  >  Support Forum  >  900HP DigiMesh Bug? - Find Neighbor Prevents Sleep
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

900HP DigiMesh Bug? - Find Neighbor Prevents Sleep

0 votes
When running xbee hp900 in digimesh synchronous sleep mode and locally (on a remote device with SM= 8 ) issuing an AT=FN, find neighbor, command the xbee stays awake for multiple sleep cycles (3-4). During this time the xbee continually consumes around 35ma for multiple sleep cycles (i.e. it does not go into a low power sleep state when the network is sleeping). During this time there is no associate led indication. This increases our power consumption to the point where we cannot use FN however we must be able to find the xbee neighbors. Does anyone know if there is a work-around for this? Or am I missing something?

Thank you!
asked Jun 11 in DigiMesh Proprietary Mesh Networking by rwcoates New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

+1 vote
Check your NT command value. You may need to adjust it so that it is less than your Wake time.
answered Jun 12 by mvut Veteran of the Digi Community (1,105 points)
0 votes
Thanks mvut. The manual says for NT: "Node Discover Timeout. The amount of time a node will spend discovering other nodes when ND or DN is issued. This value is used to randomize the responses to alleviate network congestion." I didn't think to use it for FN, but it works! I set it to the minimum 0x20 (3.2 sec) and it seems to be working fine for me. Thank you!
answered Jun 18 by rwcoates New to the Community (2 points)
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...