Home  >  Support  >  Support Forum  >  My Xbee 900 pro S3B unit are dropping packets?

My Xbee 900 pro S3B unit are dropping packets?

0 votes
I have two Xbee 900 Pro S3B modules setup and communicating.

The one sends a signal from a sensor and the other receives the signal and processes it further.

When the modules are inactive (sensor not active) it loses comms and drops a couple of packets before the receiver starts receiving signals again.

What is happening? No Sleep mode is activated.
How do I setup the radios to be always on and never drop data?
asked Jun 5 in DigiMesh Proprietary Mesh Networking by Arnold New to the Community (3 points)

Please log in or register to answer this question.

4 Answers

0 votes
What kind of data is being sent back and forth? What is sending the data to the radio and how it is connected?
answered Jun 5 by mvut Veteran of the Digi Community (2,054 points)
0 votes
I have the xbee connected to a Arduino Leonardo with Xbee socket onboard.

I send the letter "p" with serial1 from the arduino to xbee and receive it again with a similar setup.
answered Jun 5 by Arnold New to the Community (3 points)
So what is the sensor connected to?
0 votes
the sensor is connected to the arduino, but that part works.

It is an ADXL345 acceleromete that picks up a single tap ("p"). This data is captured by the arduino and transmitted as a single letter "p" from the arduino to the xbee using serial1.

On the other side the xbee is connected to a similair arduino that looks for the letter "p" on serial1. when the letter "p" is received a LED is pulsed to indicate this.


Everything works, the sensor provides the output every time and this I have tested already. I now added the xbee to get the signal remotely (I plan on using this up to 1.3km) but for now I need to sort it out while on my desk first (with Xbee on the lowest power setting)
answered Jun 5 by Arnold New to the Community (3 points)
0 votes
Problem solved, I messed up some programming of timers(overflows) :(

The Xbee is working fine
answered Jun 6 by Arnold New to the Community (3 points)
Contact a Digi expert and get started today! CONTACT US
...