Home  >  Support  >  Support Forum  >  Computer to xbee communication

Computer to xbee communication

0 votes
Hi all,

I have a problem that's killing me, although I expect it's something simple. I'd basically like to have an xbee with a PWM output that controls a LED, and send values from a computer. I looked the tutorial "PWM output with an LED", configured the XBee module and wired it, and I also configured the emitter XBee correctly, but I cannot for the life of me figure out what I should say (by terminal) to the first one so that the intensity of the LED varies.

Basically we're talking about saying "put the PWM output to 127" (or whatever value).

Thanks a lot in advance for any help!
asked May 14 in IEEE 802.15.4 by gbozovic New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Which XBee modules are you referring to and what firmware version is installed?

What sample are you referring to? Can you provide a link?
answered May 15 by mvut Veteran of the Digi Community (1,625 points)
0 votes
Sorry if I wasn't clear enough. I'm using series 1 xbee modules. I tried for instance the input with a potentiometer:

http://examples.digi.com/sensors/802-15-4-analog-input-with-a-potentiometer/

and output with PWM:

http://examples.digi.com/lights-motors-more/802-15-4-pwm-output-with-an-led/

However both do not communicate, and I would be surprised if they did: on the potentiometer side, the xbee is configured to take an analog input and transmit it. On the receiver side, the module is configured as PWM output, but nowhere is it told based on what this PWM output should be set. So both do not communicate, and I also don't know how to transmit this PWM information from a PC connected to a xbee module.

I'm sorry if this is not clear, I have the impression that I'm missing something big here, so I can't phrase it better...
answered May 16 by gbozovic New to the Community (1 point)
Contact a Digi expert and get started today! CONTACT US
...