Home  >  Support  >  Support Forum  >  XBP24BZ7 communication problem
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

XBP24BZ7 communication problem

0 votes
I have a network with pro modems XBP24BZ7. Then I did follow tests:

- coordinator api & end device api mode: everything works just fine (data is coming in as expected)

- the same coordinator api & router api: NO communication at all

- coordinator api (but low power version and modem XB24-ZB) with router api from above (XBP24BZ7 modem) communication is just fine !!

Just to make sure: I use latest firmware, and PAN ID are all the same.

Can you help and explain what I might be doing wrong. Or what I am missing.

Any help would be greatly appreciated!

Thanks
kasper
asked May 13 in ZigBee PRO Featureset (and legacy ZNet 2.5) by KasMas New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
Hello kasper,

I found that you were atleast able to try the XBee Pro Series 2B modules out. You may be able to help me.

I was just able to independently detect two of them one-by-one on XCTU-v6.1.1 and then when I used two USB cables, I was able to detect only one radio module. FYI, I am using USB explorers from sparkfun both of which give characters back on loopback (DOUT <--> DIN).

Both modules were ZigBee Router AT when I had detected them independently.

But now, both of them don't get detected. XCTU always asks to do reset and wait for 10 seconds. I tried all methods of recovery and resetting like removing slowly the module from adapter and insert back with RESET connected to GND; I used either both or one of these techniques for resetting. Today I started trying with a bread board.

If you could guide me as to how to proceed, it would be great.

Have I damaged my modules?

Thanking you
Yours sincerely
Shubham Jain
answered May 15 by shubhamj84 New to the Community (1 point)
0 votes
I solved the problem, on application level.

@Jain:

most probably you have set your routers as end devices and played around with the sleep time.

Connect your radios with a FTDI cable and open XCTU, then connect GRND with DIO (commissioning button) --> this will wake your radio for 30 seconds. Then click "read" in XCTU and change sleep settings (back to zero if you want to act them as routers only). If they fell asleep in the meantime, reconnect GRND and DIO1 again ...

succes and regards
answered May 26 by KasMas New to the Community (2 points)
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...