Home  >  Support  >  Support Forum  >  Help with driver build on Linux core - fixdep is core dumping during build
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Help with driver build on Linux core - fixdep is core dumping during build

0 votes
I have downloaded the dgrp-1.9 driver package (4000286_S) to build on Linux kernel version 2.6.32-431.3.1.el6.i686. When I try to build it, I get a core dump from the fixdep script. What is wrong with my environment?

/bin/sh: line 1: 17249 Bus error (core dumped) scripts/basic/fixdep /home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/.dgrp_common.o.d /home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/dgrp_common.o 'gcc -Wp,-MD,/home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/.dgrp_common.o.d -nostdinc -isystem /usr/lib/gcc/i686-redhat-linux/4.4.7/include -Iinclude -I/usr/src/kernels/2.6.32-431.3.1.el6.i686/include/uapi -I/usr/src/kernels/2.6.32-431.3.1.el6.i686/arch/x86/include -include /usr/src/kernels/2.6.32-431.3.1.el6.i686/include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -fstack-protector -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_AVX=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Wframe-larger-than=1024 -Wno-unused-but-set-variable -fomit-frame-pointer -g -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-dwarf2-cfi-asm -fconserve-stack -I/home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/2.6.27 -I/home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/2.6.27/include -I/home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/2.6.27/../../commoninc -DDIGI_VERSION=\""1.9-31"\" -DDGRP_TRACER -DMODULE -D"KBUILD_STR(s)=\#s" -D"KBUILD_BASENAME=KBUILD_STR(dgrp_common)" -D"KBUILD_MODNAME=KBUILD_STR(dgrp)" -D"DEBUG_HASH=17" -D"DEBUG_HASH2=6" -c -o /home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/.tmp_dgrp_common.o /home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/dgrp_common.c' > /home/ksummers/lbc/Downloads/digi/dgrp-1.9/driver/build/.dgrp_common.o.tmp
asked Apr 15 in Portserver TS by krsummers New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Don't see the failing portion. Can you try the following procedure and post the resulting typescript?

http://www.digi.com/support/kbase/kbaseresultdetl?id=3514
answered Apr 15 by userid0 Veteran of the Digi Community (913 points)
0 votes
The failing portion was the first line of the above after my question:

/bin/sh: line 1: 17249 Bus error (core dumped) scripts/basic/fixdep ......

I have since tried the procedure on a new machine (the target machine) and do not see the problem.

BTW, I tried to look at the core file and it had no symbols. When I re-compiled fixdep with symbols the problem went away (of course!)
answered Apr 18 by krsummers New to the Community (1 point)
Contact a Digi expert and get started today! CONTACT US
...