Home  >  Support  >  Support Forum  >  How to establish a connection between an endpoint device and a Xbee module coordinator?

How to establish a connection between an endpoint device and a Xbee module coordinator?

0 votes
Hi all,
I am working with an Xbee S2 module from digi for a university project. The goal is to send messages to a device that is supposed to turn ON/OFF a light.
This device comes from a particular company (Cleode), that build a whole bunch of zigbee devices for home applications.
I am using XCTU for this project and when I establish the connection between the Xbee module and my device, it is only one directionnal: from the Xbee to the device. I have however the SL, SH and network addresses of the device.
My problem is that I can't, in any way, send any message to the device (I use the console in API mode).
Does anyone have a clue to tell me why I can't control my device from the Xbee module? Is there a step I am missing? Particular protocol messages to send before any control communication?

Thanks a lot in advance for your help!!!!
asked Apr 14 in ZNet 2.5 by KatelineD New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
On the XBee, do you have the ZS parameter set to 2 (ZigBee-Pro Stack)?

If the third-party ZigBee radio is expecting a command from the Home Automation Profile, then the XBee is likely not going to support it. If it's a normal ZDO command, it should go through properly. Can you share the API frame you're sending?

-Charles
answered Apr 21 by Chiablo Community Contributor (109 points)
selected Apr 22 by KatelineD
Dear Charles,
Thanks a lot for your answer!
Unfortunately yes, the third-party devices I am using expect specific command from the Home Automation Profile... I just wanted to be sure that it was an incompatibility problem and nothing else :)
Dear KatelineD,

Hi, I'm working on a similar project, however I can't even connect my XBEE to the third party device. Would you have any advice?

Thanks in advance!
@michellechia

Just make sure ZS=2 and it should allow third-party ZigBee radios to associate. ZS=0 is the default and this adds an additional byte which is Digi specific to prevent non-Digi radios from associating and communicating. Other than that, PAN ID, Channel Mask, and encryption settings may also prevent association from occurring.
Dear @Chiablo,
Thanks for the reply! Yups I've set ZS = 2. However the third party device is actually a ZLL Phillips LivingColor. I suspect it could be due to the network security key that ZLL devices have that is preventing me from doing the association?

Thank you for your reply!
Contact a Digi expert and get started today! CONTACT US
...