Home  >  Support  >  Support Forum  >  initializing CS0 for NS7520
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

initializing CS0 for NS7520

0 votes
Hello,

I am trying to write a java test case for a ns7520 board with eclipse.
My debugger is usbWiggler.

My problem is about initializing the flash.
As on this kind of boards, flash has attached to CS0, I have to configure CS0.

My own configuration is like this, but it does not work !
Code:
// Configure CS0(flash) int memory_controller1[] = { 0x02000001 }; int memory_controller2[] = { 0xF3C00574 }; int memory_controller3[] = { 0x00000004 }; boolean result5 = ma.WriteMemory(0xffc00010, ma.DecodeAddressSpace("MMU-off"), false, memory_controller1); boolean result6 = ma.WriteMemory(0xffc00014, ma.DecodeAddressSpace("MMU-off"), false, memory_controller2); boolean result7 = ma.WriteMemory(0xffc00018, ma.DecodeAddressSpace("MMU-off"), false, memory_controller3);

Thanks in advance,
asked Apr 14 in Embedded Devices by amir.ahmadi New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
do the same register values work if set via JTAG debugger? directly through the debugger's prompt or via debugger's shell?

via C code?
look at
C:\netos75\src\bsp\platforms\connectem\cs.c
function:
void customizeSetupCS0(WORD32 * ramSize)
answered Jun 2 by LeonidM Veteran of the Digi Community (561 points)
Contact a Digi expert and get started today! CONTACT US
...