Home  >  Support  >  Support Forum  >  There is no libQtMultimedia in \lib.
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

There is no libQtMultimedia in \lib.

0 votes
I validated "MPlayer media player" and "Qt for Embedded Linux example applications" at configure and I rebuild rootfs.

But, there is no libQtMultimedia in \lib.

Must libQtMultimedia exist in Video Graphics Item Example and Video Widget Example ?

env : Windows7 > VMware > ubuntu12.04

Digi ESP for Embedded Linux
Version: 2.0 for Digi Embedded Linux 5.9.2.1
Build id: 20120709 DEL-5.9.2.1
asked Mar 27 in Linux by chung New to the Community (30 points)

Please log in or register to answer this question.

4 Answers

0 votes
libQtMultimedia.so is part of the Digi Embedded Linux (DEL) 5.7/5.9 ESP development toolchain.
After installing DEL-5.9 (and updating via package manager to latest version 5.9.6.2) you can find it:

# find /usr/local/DigiEL-* -iname \*libQtmulti\*
DigiEL-5.9/x-tools/arm-cortex_a8-linux-gnueabi/arm-cortex_a8-linux-gnueabi/sysroot/usr/lib/libQtMultimedia*

In order to get it added to your rootfs, just add the Qt example applications to your rootfs, or use add_files.sh to copy it during rootfs build process manually
answered Apr 4 by User143 New to the Community (35 points)
0 votes
I added "Qt for Embedded Linux example application" to configure. And I remade rootfs.

But, there are no libQtMultimedia* in /build/rootfs/lib/.

Another way,

I copied DigiEL-5.9/x-tools/arm-cortex_a8-linux-gnueabi/arm-cortex_a8-linux-gnueabi/sysroot/usr/lib/libQtMultimedia* in /build/rootfs/lib/.

I operated "Video Graphics Item Example" and "Video Widget Example".
An error disappeared.
The frame was displayed, but a picture is not displayed.
answered Apr 7 by chung New to the Community (30 points)
0 votes
I cannot yet "5.9.6.2"
answered Apr 7 by chung New to the Community (30 points)
0 votes
I upgraded to 5.9.6.2.

I added "Qt for Embedded Linux example application" to configure. And I remade rootfs.

But, there are no libQtMultimedia* in /build/rootfs/lib/.
There is phonon.

I copy it by manual.

Thank you.
answered Apr 7 by chung New to the Community (30 points)
Contact a Digi expert and get started today! CONTACT US
...