Home  >  Support  >  Support Forum  >  AT DN (firmware 0x8067) : status 0x40
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

AT DN (firmware 0x8067) : status 0x40

0 votes
All RF module are upgraded to the last Digimesh firmware 0x8067 and when a module send an ATDN command, the answer appears with a status 0x40 which is unknown in the documentation.
Is it a bug ?
Olivier
asked Mar 6 in DigiMesh Proprietary Mesh Networking by nuage125 New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
Similar problem here with firmware 8162, got 0x80 as command status.

I find these module rather buggy...

does "remote address" is as expected?

in my case it shows the same as the node discovered which is odd, here a sample:

7E 00 23
97 01
00 13 A2 00 40 78 8F C4
FF FE
4E 44
80 FF FE
00 13 A2 00 40 78 8F C4
20 00
FF FE 01 00 C1 05 10 1E
C9
answered Mar 14 by reynaldomic New to the Community (3 points)
0 votes
I found the extended command status description (on a more up-to-date doc)

The least significant nibble indicates the command
status:
0 = OK
1 = ERROR
2 = Invalid Command
3 = Invalid Parameter
The most significant nibble is a bitfield as follows:
0x40 = The RSSI field is invalid and should be ignored.
Software prior to version 8x60 did not include RSSI
information
0x80 = Response is a remote command.

The doc is this one http://ftp1.digi.com/support/documentation/90002173_L.pdf
answered Mar 17 by reynaldomic New to the Community (3 points)
Contact a Digi expert and get started today! CONTACT US
...