Home  >  Support  >  Support Forum  >  Why does Zigbee Coordinator firmware reset my Netduino / arduino?

Why does Zigbee Coordinator firmware reset my Netduino / arduino?

0 votes
I have a Series 2 XBee running the Zigbee coordinator API firmware (version 2170) and periodically there is a huge flood of data on the RX line, followed by a reset that also resets my microcontroller.

I have temporarily stopped the reset by removing the XBee shield from the microcontroller (Netduino) and connecting it via jumper wires, however the flood of data still occurs followed by two packets:

ModemStatusResponse: 1
ModemStatusResponse: 6

Everything I have found online indicates this is some issue with the Zigbee stack and arduino platform, and is resolved by replacing the Zigbee firmware with ZNET 2.5 firmware - Is this really necessary?

I have captured the data "flood" bytes and can provide if that would help diagnose the problem, or if it is as simple as a config setting or tying a pin to GND / 3.3V, I am willing to go there. Replacing the firmware just seems like a bandaid rather than a true fix...
asked Feb 10 in ZigBee PRO Featureset (and legacy ZNet 2.5) by GDSever New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
The firmware version you are using is out of date. Have you tried upgrading it to the current 21A7 version of code?
answered May 9 by mvut Veteran of the Digi Community (1,625 points)
0 votes
Yes, I have upgraded and seen the same issue. Thank you for the suggestion though!
answered May 9 by GDSever New to the Community (2 points)
Contact a Digi expert and get started today! CONTACT US
...