Home  >  Support  >  Support Forum  >  Getting XBee WiFi Module To Work Correctly In TCP Mode With Web Browser
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

Getting XBee WiFi Module To Work Correctly In TCP Mode With Web Browser

+1 vote
Hi, recently I purchased a XBee Wifi S6B module to be used with Ardunio Uno setup as a web server to display sensor data. During initial test I able to successfully configure the WiFi module so that it connects to the wireless network and I can telnet from a desktop computer to the module using Putty and X-CTU terminal on port 80. But when I try using a web browser (Chrome or FireFox) to connect to the module I can never see the browser's "GET" response on the X-CTU's terminal. The module is setup for "transparent" mode with firmware 2021. While I am somewhat of a newbie on this, I would think that if the telnet works on port 80 then I should at least see the "Get" response when the web browser quires the IP address of the module? Am I missing something or perhaps have the module incorrectly configured? Any help that you can provide would be greatly appreciated.
asked Dec 10, 2013 in RF Solutions and XBee by RSavage1 New to the Community (1 point)
I have the same problem with 2021, but it works with 2004. API mode doesn’t work either with 2021: GET is not propagated to the UART.  I did a search and found that other people complained about the same:
http://www.youtube.com/watch?v=nVIeRJoiuhY
http://godydeeps.wordpress.com/2011/10/11/xbee-wifi-digi/

Please log in or register to answer this question.

2 Answers

0 votes
Hi RSavage1,
I found the same problem with 2021. The GET method was displayed in the X-CTU's terminal in the previous version 2004 and my response to the GET method was displayed in browser. It stopped working when I updated the firmware to 2021. However, if I send response to GET right after entering the IP address in the browser, the web page is displayed correctly.
answered Dec 11, 2013 by iota New to the Community (1 point)
0 votes
This is a known bug and a fix has been implemented in the next revision of the firmware. It is still under QA review before release. GET and POST are both "intercepted" by the internal web server. Problem is that nothing is done with the data and eventually a lockup occurs.

Keep checking here for updates as to firmware release.

Cheers!
answered Dec 11, 2013 by Rocker1446 Community Contributor (71 points)
Hi
Still no update. Terrible.
When problem will be solved? I want to make my customers able to set SID & password trough web page
I am new to xbee wifi. I still can't use xbee wifi to pull even a simplest web page or do a GET command. It was so easy using arduino wifi shield and I understood what I was doing. With the xbee wifi, I'm not sure what I'm doing. Is there any tutorial for beginners?

What about the new firmware promised?
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...