Home  >  Support  >  Support Forum  >  Issues getting 2 Xbees to Communicate in simple setup
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

Issues getting 2 Xbees to Communicate in simple setup

0 votes
Trying to get 2 XbeePro modules to communicate. One is Xbee pro S1 and the other is XbeePro.
the PRO is XBP24-ACI as is the PRO S1. I don't know much about XBee, is it possible the XBEE PRO and XBEE PRO S1 are non-compatible???
CONFIGURATION #1 (imgr)
CONFIGURATION #2 (imgr)
They are both being setup with the factory default config. then I go and modify PAN ID to 1999:

(CH)CH=0
(ID)PAN ID=1999
(MY)Source Address = 0
(DL)Destination Low = 0
(BD)BaudRate = 3 (9600)

I have one hooked to the PC via a USB adaptor,
and the other is hooked to a breadboard with pin1 to 3.3v, pin10 to ground, and pin2(Dout) attached to Pin3(Din) to make it an ECHO of whatever it recieves.

In the X-CTU terminal I've tried to do the following to detect the breadboard node:

+++OK
ATCH
0
ATID1999
OK
ATRE
OK
ATWR
OK
ATND

<nothing happens here, just returns down to next line and stops>

Just curious what I'm missing / incorrectly setting for the module to detect the other
asked Dec 2, 2013 in RF Solutions and XBee by jambox5 New to the Community (0 points)
edited Dec 11, 2013 by jambox5

Please log in or register to answer this question.

2 Answers

0 votes
XBee and XBee PRO radios of same series are compatible with each other.
Try setting SC to maximum to scan all channels.
answered Dec 5, 2013 by 16ksa23 Veteran of the Digi Community (369 points)
And how do I do that? I can see ATSC is set to 1FFE, but in X-CTU's modem config I don't see which value to set or what "maximum" value is. is it 1FFF,FFFF? a wee bit more detail would be excellent
Just ensure they both have the same value. XCTU hints you for the maximum value allowed, tough.
0 votes
Hello jambox5,

If CH returns 0 it means that the module is not connected. Check your parameters and/or paste here the XCTU's profiles. Best regards,

Sebastián.-
answered Dec 10, 2013 by spastor Veteran of the Digi Community (394 points)
It looks like I got past this now
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...