Home  >  Support  >  Support Forum  >  SEP Key establishment
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

SEP Key establishment

0 votes
Hi,

I have been trying to do the key establishment with router and coordinator for quite some time now.

I have got the test keys from certicom.

Have done the similar thing as mentioned in the document.
"The ZU command with the CA Public key parameter:
7E 00 1A 08 01 5A 55 02 00 FD E8 A7 F3 D1 08 42 24 96 2A 4E 7C 54 E6 9A C3 F0 4D A6 B8 CB
The ZT command with the Device Implicit Cert parameter:
7E 00 34 08 01 5A 54 03 06 19 58 D9 5E AF 54 77 BE 7C 89 A9 4A 85 AA BB B0 8C DD 3D 0B 00 13 A2
00 40 4C 15 A4 54 45 53 54 53 45 43 41 01 09 00 10 00 00 00 00 00 00 AC
The ZV command with the Device Private key parameter:
7E 00 19 08 01 5A 56 03 EA 7F 82 1C D8 5F 0D 4F 6A 78 2B 2E 69 94 DF 1C C4 8B E8 FD 42
With X-CTU (or by similar means), write the API packets to the serial port of the XBee.
Send a write command (WR) to commit the certificate to non-volitile memory.
7E 00 04 08 01 77 72 0D
Reset the router (FR) so it will restart using the new certificate.
7E 00 04 08 01 46 52 5E
Send a verify certificate (VC) command to verify the presence of a certificate.
A returned parameter of ‘1’ indicates a certificate is present; a ‘0’ indicates one is not present.
7E 00 04 08 01 56 43 5D"

Now, I see following message from Router.
Modem Status

7E 00 02 8A 01 74

- Start delimiter: 7E
- Length: 00 02 (2)
- Frame type: 8A (Modem Status)
- Status: 01 (Watchdog timer was reset)
- Checksum: 74

Modem Status

7E 00 02 8A 02 73

- Start delimiter: 7E
- Length: 00 02 (2)
- Frame type: 8A (Modem Status)
- Status: 02 (Device joined to network)
- Checksum: 73

Zigbee Explicit RX Indicator

7E 00 18 91 00 13 A2 00 40 8B 43 7C 00 00 00 00 80 06 00 00 01 01 00 00 00 01 5E 48

- Start delimiter: 7E
- Length: 00 18 (24)
- Frame type: 91 (Zigbee Explicit RX Indicator)
- 64-bit source address: 00 13 A2 00 40 8B 43 7C
- 16-bit source address: 00 00
- Source endpoint: 00
- Destination endpoint: 00
- Cluster ID: 80 06
- Profile ID: 00 00
- Receive options: 01
- Received data: 01 00 00 00 01 5E
- Checksum: 48


But when I check with AI, got the following one at different time interval.
AT Command Response

7E 00 06 88 01 41 49 00 30 BC

- Start delimiter: 7E
- Length: 00 06 (6)
- Frame type: 88 (AT Command Response)
- Frame ID: 01 (1)
- AT Command: 41 49 (AI)
- Status: 00 (Status OK)
- Response: 30
- Checksum: BC

After a while,
AT Command Response

7E 00 06 88 01 41 49 00 36 B6

- Start delimiter: 7E
- Length: 00 06 (6)
- Frame type: 88 (AT Command Response)
- Frame ID: 01 (1)
- AT Command: 41 49 (AI)
- Status: 00 (Status OK)
- Response: 36
- Checksum: B6

Ideally I would expect 00 response with LED toggling at a rate of 2 Hz here.

Any ideas, what could be going wrong here ?
Response 36 apparently is for "Received terminate request". What exactly does that mean ?

I would appreciate any response to this question.

Thanks,
Krishna
asked Nov 7, 2013 in ZigBee Smart Energy Profile 1.1 by krishnakamathk New to the Community (3 points)
edited Nov 6, 2013 by krishnakamathk

Please log in or register to answer this question.

1 Answer

0 votes
You might find the following example application helpful:

https://idigi-se.appspot.com/edocs/getting_started/inpremise.html
answered Dec 10, 2013 by userid0 Veteran of the Digi Community (890 points)
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...