Home  >  Support  >  Support Forum  >  Wifi Xbee Module - Ad Hoc Network
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

Wifi Xbee Module - Ad Hoc Network

0 votes
I've setup two Xbee Wifi nodes into Ad-Hoc mode according to page 38 of the Difi WiFi document.

I do not see transparent communication between the serial terminal.

Is there a missing step or another tutorial for setting up Ad-Hoc Mode ?
asked Sep 12, 2013 in IEEE 802.11 by lyncas New to the Community (9 points)
What version of XBee WiFi are you using S6 or S6B?
I'm using the s6b
same problem, S6B too

Please log in or register to answer this question.

2 Answers

0 votes
If you are using the S6 module, then I would suggest going to the following website:

http://todigi.blogspot.com/2012/08/xbee-wifi-in-ad-hoc-mode.html


If you are using the S6B, ad-hoc isn't yet supported. You may be able to create a network, but data communications are not enabled. The next version of firmware will include both ad-hoc and soft AP modes that will make using a portable WiFi device such as a smartphone or tablet possible.

Check the AI status. If it is anything other than 0x00, it means the radios are not joined up to a network (in this case, just the two)
answered Sep 12, 2013 by Rocker1446 Community Contributor (71 points)
0 votes
Lyncas,

The new version of firmware (2021) is now available.

You just need to contact Digi Tech Support. Easiest way is to create a case.

http://www.digi.com/login?ReturnUrl=%2fsupport%2feservice

Once you have created a case, the support team will be able to deliver the new firmware to you.

Also, here is the link to the manual that corresponds to the 2021 firmware.

http://ftp1.digi.com/support/documentation/90002180_G.pdf
answered Oct 9, 2013 by Rocker1446 Community Contributor (71 points)
I want to send characters between 2 xbee s6b firmware 2021 in ad-hoc mode but my configation doesn't work :

the first xbee s6B configuration is :
Radio 1 - Ad-Hoc Creator

ATIDTEST
ATIP1
ATAH1
ATMA1
ATDL192.168.1.11
ATMY192.168.1.22
ATMK255.255.0.0
ATCH1

the second xbee s6b configuration is :

Radio 2 - Ad-hoc Joiner

ATIDTEST
ATIP1
ATAH0
ATMA1
ATDL192.168.1.22
ATMY192.168.1.11
ATMK255.255.0.0

i can't send characterers between the xctu terminal of the first and the second xbee.
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...