Home  >  Support  >  Support Forum  >  Can't change channel in X-CTU
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

Can't change channel in X-CTU

0 votes
Hello!
I always have a problem with channels. When I set the same Pan ID to xbee modules, they may have different channels. Then change module from coordinator to router, after that they find same channel and work. But after several time they stop working and when I check they have another channels. So, why does this happen???
PS:Sorry for my english) and thanks!
asked Aug 1, 2013 in Multipoint Proprietary by Madina888 New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
are you referring to the CH value? If so, that can't be changed. It's readable only.

To control the channel used you use the SC value:
http://www.digi.com/wiki/developer/index.php/Channels%2C_Zigbee
answered Sep 27, 2013 by kjensen8 Veteran of the Digi Community (441 points)
0 votes
If you have a secured network, and if you don't want to loose the modules after power cycle, you can set JV=0 so that the module retain its parent and search for the parent in the specified PAN ID after power ON.
In your case as said, CH value cannot be changed. It is Read-Only parameter.
You can issue NR0 to reset the networking parameters. Or write the firmware again with default settings.
answered Sep 28, 2013 by 16ksa23 Veteran of the Digi Community (363 points)
Your M2M Expert™for Businessfor Developers
Newsletter SignupYouTubeGoogle+FacebookCopyright © 1996-2013 Digi International Inc. All rights reserved. Legal
...