Home  >  Support  >  Support Forum  >  Trouble with Connecting, please wait... deadlock
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Trouble with Connecting, please wait... deadlock

0 votes
Hello, I'm using a CP-DIS-M22 SN:(S)V073949848 and suddenly it works from a random time but suddenly it only shows the "Connecting , please wait..." and never gets connected, if I connect from my PC using any standar VNC client it (UltraVNC, RealVNC) I can connect perfectly, I tried pressing the button on front of the device but no change is made, except all leds flash intermitent and then only System Status Led flash at 1 sec period but no change on screen display, The only solution I have found is to cut power and restablish it to reconnect, but since device is located inside a cabinet is not posible to my operators to reach the power plug to disconnect it from source. Any help will be appreciated.

Notes: I can enter to device admin page via web page but it doesn't show any status on it.

I'm using last firmware 82001357_E.dwn on it.

Thank you.
asked Feb 19, 2010 in ConnectPort Display by jtejada New to the Community (17 points)

Please log in or register to answer this question.

5 Answers

0 votes
Hi there,

Let's start with the basics:

1. Have you always seen this issue, or did this issue recently start happening?

2. About how often does this issue happen?

3. Is there any kind of pattern to this issue? For example, does it seem to happen every so many hours, or at a certain time every day, or only when certain software is being run on the host PC?

The next time this issue happens, please collect the following information BEFORE cutting power:

1. Can you ping the M22 from the host PC?

2. Can you log into the M22 webpage from the host PC?
answered Feb 22, 2010 by jeremym Veteran of the Digi Community (1,001 points)
0 votes
Hi

Here are some answers to your questions.

1. Have you always seen this issue, or did this issue recently start happening?
A: Its been some time like 3 months ago, at the begining I thought it was related to a network issue, and after a review from our hardware network expert he didn't found any problem, then I started to think it was related to duplicated IP problems, so we made a review of all IP addresses implemented, didn't found anything, anyway we setup new IP addresses for Remote PC and M22 device, but still the same problem.

2. About how often does this issue happen?
A: There is no a time basis on the frecuency of the issue, some time a couple of hours, some times days, but after the deadlock is present it never came back online until you reset M22 device.

3. Is there any kind of pattern to this issue? For example, does it seem to happen every so many hours, or at a certain time every day, or only when certain software is being run on the host PC?
A: There sin no pattern on frecuency of this issue. The remote PC is running only 1 application, a SCADA software from Citect (www.citect.com) anyway I still can connect and control it using a VNC client in local and other PCs.

The next time this issue happens, please collect the following information BEFORE cutting power:

1. Can you ping the M22 from the host PC?
Yes, I can still ping the device, only running a ping -T it shows a esporadic timeout.

2. Can you log into the M22 webpage from the host PC?
Yes, I can log into the M22 webpage, however the answer is more "slow" but I can't still made modifications, if I can do a reboot from this page, but since this M22 is password protected and operators doen't have web access it was not posible to implement this solution.

One thing that I found recently from this M22 device (we have other) is that some times I used to enable the VNC server to monitor what operators seen on screen, but each time I try to connect to M22 using a VNC client the M22 doesn't allow connection and reboots. This operation works fine on other M22 device.
answered Feb 23, 2010 by jtejada New to the Community (17 points)
0 votes
Thanks for the info.

What Operating System is the host PC running?

What version of VNC is running on the host PC? And is it UltraVNC, or one of the other variants?

Is the optional Video Hook "mirror" driver running (if you're using UltraVNC)?

What is the display resolution of the host PC and the M22?

Are the other M22 and related host PC connected to the same Ethernet switch as the M22 and host PC that are having this problem?
answered Feb 23, 2010 by jeremym Veteran of the Digi Community (1,001 points)
0 votes
Hi,

More answers, thank you:

What Operating System is the host PC running?
A: Is Running Windows XP SP3

What version of VNC is running on the host PC? And is it UltraVNC, or one of the other variants?
Actually is running UltraVNC Server 1.0.8.2, It was running originally wth RealVNC 4.1.2 but it was the same error, change it to UltraVNC thinkink it was RealVNC server problem

Is the optional Video Hook "mirror" driver running (if you're using UltraVNC)?
Yes optional video hook mirror driver is running

What is the display resolution of the host PC and the M22?
Remote PC 1024 x 768 (60 Hertz, 32 bit color)
M22 has 1024 x 768 (60 Hertz, 24 bit color)

Are the other M22 and related host PC connected to the same Ethernet switch as the M22 and host PC that are having this problem?
We have other M22 connected to other Remote PC connected to the same switch that is not have this problem

I actually removed the M22 Device from operator station and take it to my place to make a deep testing and I found that after a deadlock if I don't reboot inmediatly after a couple of hours of problem is present it does lost ping connection and not is possible to get connected to M22 using a web client nor from Remote or other PC, it seems that M22 deadlock blocks any communication, doing a warm reboot on M22 restablish all functionality to M22. Also there has been intermitten reboots on M22 without a time base, just suddely you can see on screen a reboot of device.

Thank you.
answered Feb 26, 2010 by jtejada New to the Community (17 points)
0 votes
It sounds like the hardware might be defective. If you want to open an RMA request to get the unit looked at and possibly repaired, we can do that. Just send an e-mail to support.wizards@digi.com and reference this forum thread #7108.

Thanks for your time troubleshooting this.
answered Mar 1, 2010 by jeremym Veteran of the Digi Community (1,001 points)
Contact a Digi expert and get started today! CONTACT US
...